Towne-Biz Plus Security Upgrade

On May 13, 2017, Towne-Biz Plus will undergo a security upgrade that will require all users to use a modern version of your preferred browser.

What do I need to do?

Prior to May 13th, check which version of your browser you are using. If you are using one of the browser versions below, no further action is needed:

  • Google Chrome version 30 (or higher)
  • Mozilla FireFox version 27 (or higher)
  • Internet Explorer 11

However, if you are not running these browser versions, then you will need to update your browser in order to continue accessing Towne-Biz Plus.

For your convenience, we have provided the following links to help you download a more current version of your preferred browser: Google Chrome | Mozilla Firefox | Internet Explorer

What will happen if I don't update my browser?
If you are on an older browser version and do not perform the necessary browser updates, you will no longer be able to access Towne-Biz Plus after May 13th. Instead, you will receive a message that your browser is out of date.

For your convenience, we have provided links to update the most popular browsers that are support by Towne-Biz Plus: Google Chrome | Mozilla Firefox | Internet Explorer
Why do I need to use an updated browser?
Your security is always our top priority. Due to industry recommendations for securing web browser sessions, support for any SSL/TLS versions below TLS v1.1 will be removed on May 13. The SSL protocol will be replaced by the TLS protocol for secure web browser sessions (HTTPS). In order to provide strong cryptography, the web servers used to deliver your online banking experience will now only support TLS versions v1.1 and v1.2.